All in All
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 27521 | Accepted: 11266 |
Description
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence person compression VERDI vivaVittorioEmanueleReDiItalia caseDoesMatter CaseDoesMatter
Sample Output
Yes No Yes No
Source
代码:一开始想多了,想着要查找的串的第一个字母对应另一个串中的很多位置怎么办。。。其实不用只要匹配了一个字母待匹配的串就少了一个字母,不需要回溯。。所以直接设置两个指针直接模拟就可以了。。
代码:
#include <iostream>
#include <string.h>
using namespace std;
string s1,s2;
int len1,len2;
int main()
{
while(cin>>s1>>s2)
{
int len1=s1.length();
int len2=s2.length();
int i=0,j=0;
while(j<len2)
{
if(s1[i]==s2[j])
{
i++;
j++;
if(i==len1)
{
cout<<"Yes"<<endl;
break;
}
}
else
{
j++;
if(j==len2)
{
cout<<"No"<<endl;
break;
}
}
}
}
return 0;
}