杭电acm1037

Keep on Truckin'

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8626    Accepted Submission(s): 6024


Problem Description
Boudreaux and Thibodeaux are on the road again . . .

"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"

"Don't worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"

"We're not going to make it, I say!"

So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?
 

Input
Input to this problem will consist of a single data set. The data set will be formatted according to the following description.

The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.
 

Output
There will be exactly one line of output. This line will be:

   NO CRASH

if the height of the 18-wheeler is less than the height of each of the underpasses, or:

   CRASH X

otherwise, where X is the height of the first underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler). 
The height of the 18-wheeler is 168 inches.
 

Sample Input
      
      
180 160 170
 

Sample Output
      
      
CRASH 160
本来这是一道简单题,可是起先题目看不懂,可是看了网上别人的解释说这是输入3个数,找出里面比168小的数集,然后再在数集里筛出最大数。
所以就用了循环,然后提交却总是超时了 抓狂
后来看了下别人的 安静是借鉴哦!。。。才明白了。
其实只要输入3个数,只要里面有小于168的,随表挑一个就行了,用不着排序循环什么傻傻的 敲打
所以,实践出真知啦,自己反复思索,体会才更加深刻 快哭了
以下是AC代码
#include <stdio.h> 
int main(){ 
int a,b,c; 
while(scanf("%d %d %d",&a,&b,&c)!=EOF){ 
      if(a<=168) printf("CRASH %d\n",a); 
      else if(b<=168) printf("CRASH %d\n",b); 
      else if(c<=168) printf("CRASH %d\n",c); 
      else printf("NO CRASH");  
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值