hdu 1395 2^x mod n = 1

hdu 1395 2^x mod n = 1
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11835    Accepted Submission(s): 3684




Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.


 


Input
One positive integer on each line, the value of n.


 


Output
If the minimum x exists, print a line with 2^x mod n = 1.


Print 2^? mod n = 1 otherwise.


You should replace x and n with specific numbers.


 


Sample Input
2
5
 


Sample Output
2^? mod 2 = 1
2^4 mod 5 = 1
/*
方法一:暴力搜索 + 同余定理 
    */
#include<cstdio>
int main()
{
    int m,n,t;
    while(scanf("%d",&n)!=EOF)
    {
        m=n%2?2:0;
        t=1;
            while(m!=1&&m)
            {
                m=m*2;
                m%=n;
                t++;
            }
         if(n%2==0||n==1)   printf("2^? mod %d = 1\n",n);
         else   printf("2^%d mod %d = 1\n",t,n);
    }
    return 0;

}


/*
方法二: 蒙哥马利幂模运算 
    */
#include<cstdio>
int Montgomery(long long a,int b,int c)
{
    long long ans=1;
    while(b)
    {
        if(b&1)
        ans=(ans*a)%c;
        b>>=1;
        a=(a*a)%c;
    }
    return ans;
}
int main()
{
    int m,i;
    while(scanf("%d",&m)!=EOF)
    {
          if(m%2==0||m<=1)   //如果不加 m<=1 会出现 TLE .
          printf("2^? mod %d = 1\n",m);
          else
          for(i=1; ; i++)
          {
                if(Montgomery(2,i,m)==1)
                {
                  printf("2^%d mod %d = 1\n",i,m);
                  break;
                }
         }
    }
         return 0;
}
        
        
        
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值