记一次Maya使用入门

目录

Maya基本工作流程

下载他人资源,安装MAYA本地,

选择中间输入序列号

直接打开Scene,无用

需先设置项目目录

打开场景为空,如何查看错误

错误参考索引

swatches file depend node not found

重启Maya,可能出现一堆错误

安装 Vray 插件和 xgen 插件

图片文件属性,绝对路径改相对路径

错误: vrayUpdateAE.mel line 482: 找不到过程"vrayAddMenuPostCommand"。 // 

错误: line 1: 找不到过程"vraySyncAnimFlags"。 // 

Maya插件科普

Xgen是什么东西

Vray是什么东西

渲染器“arnold” 是什么东西


Maya基本工作流程

下载他人资源,安装MAYA本地,

预留足够空间

预留足够空间

预留足够空间

 

选择中间输入序列号

反正就是选中间就对了

无论,左右,通过网络就是作妖

以Adobe和AutoDesk的尿性,你觉得乱选,有你好受的?

还是坚持国人的选择,随波逐流在这一刻并不是缺点

直接打开Scene,无用

(记得打开场景前,一般需先设置项目路径,具体原因可参考文章最后面相对路径解释)

这是正确加载

不正确的New Scene,原因很多

(这里主要是场景文件错误)

并没有场景文件,无法直接看出场景文件在哪里(后缀是 .mb)

.Mel文件如何打开,不要双击,没用

模型(场景)制作完成后,如何直接导出到Unity

光是导出fbx,在MAYA操作确实很简单,但明显没有贴图,也就是只有mesh,甚至连动画,环境光也是没有的

可参考,程序员写的,导出方案:

https://www.cnblogs.com/123ing/p/3703938.html

 

需先设置项目目录

网上下载的maya都需要如此

场景目录: scenes/xxx

打开场景为空,如何查看错误

右下角这里

错误参考索引

swatches file depend node not found

尝试找问题答案

https://tieba.baidu.com/p/996558102?red_tag=2835311992

GPU数据

重启Maya,可能出现一堆错误

又是各种版本地狱,网上买的老师教程内容,或者是没标明用什么版本打开,或者是我没看到,但这明显的各版本的各种坑,非AutoDesk内部人员或非多年从业人员,肯定都不能搞定,各位知识付费还需谨慎

onSetCurrentLayout "Maya Classic";
file -f -new;
preferredRenderer -makeCurrent;
// 警告: file: D:/Program Files/Autodesk/Maya2017/scripts/startup/rememberViewportSettings.mel line 29: 主动立体在启用 Aero 的情况下不起作用。主动立体已禁用。 // 
// 结果: 无标题 // 
commandPort -securityWarning -name commandportDefault;
# 错误: file: D:/Program Files/Autodesk/Maya2017/plug-ins/xgen/scripts/xgen.mel line 116: UnicodeEncodeError: file D:\Program Files\Autodesk\Maya2017\plug-ins\xgen\scripts\xgenm\xgGlobal.py line 183: ascii # 
// 错误: 无法执行 xgen.mel。 // 
// AbcExport v1.0 using Alembic 1.5.8 (built Dec 24 2015 17:28:19) // 
# pymel.core : Updating pymel with pre-loaded plugins: invertShape, mayaHIK, GamePipeline, CloudImportExport, curveWarp, tiffFloatReader, MASH, poseInterpolator, bifrostvisplugin, ATFPlugin, hairPhysicalShader, ikSpringSolver, ik2Bsolver, xgenToolkit, AbcExport, retargeterNodes, gameFbxExporter, VectorRender, OpenEXRLoader, lookdevKit, Unfold3D, Type, modelingToolkit, deformerEvaluator, renderSetup, GPUBuiltInDeformer, fbxmaya # 
// AbcImport v1.0 using Alembic 1.5.8 (built Dec 24 2015 17:28:19) // 
updateRendererUI;
// 警告: file: D:/Program Files/Autodesk/Maya2017/scripts/others/supportRenderers.mel line 64: 此场景使用的渲染器“arnold”当前不可用。将改用“mayaSoftware”渲染器。 // 

 

安装 Vray 插件和 xgen 插件

大部分版本问题,都来自于插件的版本冲突,maya本身能有多少冲突?

Vray是本人最烦的东西,是因为Vray本身维护版权的原因,不熟悉,还是因为Vray的公司后台很霸道?,既然那么重要,为什么不内嵌整合?

Xgen 不知道哪个版本开始Maya里面已经内置了,不需要单独安装,下面链接只是参考,无实际用处

http://www.gfxcamp.com/?s=xgen+%E6%8F%92%E4%BB%B6

图片文件属性,绝对路径改相对路径

手动设置路径?是说指定工程路径么?在file---project----set
下指定你以前建好的工程目录,如果你以前的贴图都保存在sourceimages下的话就能认回来了

 

错误: vrayUpdateAE.mel line 482: 找不到过程"vrayAddMenuPostCommand"。 // 

参考评论区

http://www.gfxcamp.com/maya-vray-3-6/

评论区并没有解决方法,分析了一下

file -force -options "v=0;p=17;f=0" -type "FBX export" -pr -ea "D:/Projects/DynamicHair/Assets/nvbu.fbx";
// Logfile: "C:\Users\HUAWEI\Documents\maya\FBX\Logs\2017.0.1\maya2017exp.log"
// D:/Projects/DynamicHair/Assets/nvbu.fbx // 
// 错误: file: D:/Program Files/Autodesk/Maya2017/vray/scripts/vrayUpdateAE.mel line 482: 找不到过程"vrayAddMenuPostCommand"。 // 

分析的流程大概如下

1.file export fbx ,这命令行需要参数:option -pr -ea

2.用到-ea,所以会调用到脚本:xxxx/varUpdateAE.mel

3.执行了脚本内的proc,有清晰备注和代码(暂时不知道是什么代码,但是容易阅读的)

4.vrayUpdateAEJobBase()里面应该会淡出一个menu,正常的流程大概如此,但就是报错了

5.然后就没有然后了

错误: line 1: 找不到过程"vraySyncAnimFlags"。 // 

网上没找到答案,估计是自定义,或者插件问题

Maya插件科普

科普有点太多,没时间干,还是有时间再开一个文章吧

Xgen是什么东西

Vray是什么东西

渲染器“arnold” 是什么东西

科普有点太多,没时间干,还是有时间再开一个文章吧

 

 

 

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 程序猿惹谁了 设计师:白松林 返回首页