【2020-8-8】ROS软件包自动安装依赖,安装ros_pcl

最近要把T265部署到无人机平台,编译一个软件的时候一直报ros_pcl的错误。原因是树莓派安装的ros并不是完整版,因为也不需要再树莓派上部署gazebo之类的仿真平台。

网上关于安装ros_pcl的文章基本上都已经out of date,而且都是编译安装,这样又会增加更多的问题。可以用下面的方法简化流程。

cd ~/catkin_ws/
rosdep install --from-paths src --ignore-src --rosdistro=melodic -y 

安装的包有:

ros-melodic-nodelet-topic-tools

ros-melodic-pcl-conversions

ros-melodic-pcl-msgs

ros-melodic-pcl-ros

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页